1. Foren
  2. Kommentare
  3. OpenSource
  4. Alle Kommentare zum Artikel
  5. › Desktop: Mozilla arbeitet an H.264…

Geht das nicht schon jetzt?

  1. Thema

Neues Thema Ansicht wechseln


  1. Geht das nicht schon jetzt?

    Autor: Thaodan 24.10.12 - 08:59

    Bei mir sagt Youtube.com/html5 das Firefox (16.01) das kann.

    Wahrung der Menschenrechte oder Freie fahrt am Wochenende.
    -- Georg Schramm

  2. Re: Geht das nicht schon jetzt?

    Autor: borg 24.10.12 - 09:15

    Es gibt noch mehr Viedeoquellen ausser youtube.

  3. Re: Geht das nicht schon jetzt?

    Autor: Thaodan 24.10.12 - 09:17

    Sollte nur als Beispiel dienen..

    Wahrung der Menschenrechte oder Freie fahrt am Wochenende.
    -- Georg Schramm

  4. Re: Geht das nicht schon jetzt?

    Autor: WilliWichtig 24.10.12 - 09:31

    youtube liefert webm aus und nicht h264
    Das kann der Firefox schon ne Weile

  5. Re: Geht das nicht schon jetzt?

    Autor: lestard 24.10.12 - 09:32

    Youtube-Videos sind in mehreren Codecs vorhanden. Für Firefox wird die mit WebM kodierte Variante abgespielt. WebM ist ein freier Codec und den kann Firefox out of the Box abspielen. Für andere Browser, die WebM nicht können aber dafür h264, wird eben diese Variante des Videos abgespielt.
    Da ist aber Youtube eben ein Sonderfall weil im Hintergrund Google die Fäden zieht und Google eben WebM gerne als Alternative für h264 sieht.

    Bei anderen Webseiten, die nur h264 anbieten, läuft das Video in Firefox nicht, was sich eben jetzt ändern soll.

  6. Re: Geht das nicht schon jetzt?

    Autor: Thaodan 24.10.12 - 09:41

    Nein beides siehe unten.

    Wahrung der Menschenrechte oder Freie fahrt am Wochenende.
    -- Georg Schramm

  7. Re: Geht das nicht schon jetzt?

    Autor: Thaodan 24.10.12 - 09:44

    Laut Youtube kann er es aber siehe:


    Wahrung der Menschenrechte oder Freie fahrt am Wochenende.
    -- Georg Schramm

  8. Re: Geht das nicht schon jetzt?

    Autor: nille02 24.10.12 - 09:46

    Thaodan schrieb:
    --------------------------------------------------------------------------------
    > Bei mir sagt Youtube.com/html5 das Firefox (16.01) das kann.

    Da steht nur das Firefox html5 Video und WebM kann.

  9. Re: Geht das nicht schon jetzt?

    Autor: nille02 24.10.12 - 09:49

    Thaodan schrieb:
    --------------------------------------------------------------------------------
    > Laut Youtube kann er es aber siehe:
    > imageshack.us

    Sicher, dass du Firefox benutzt?

  10. Re: Geht das nicht schon jetzt?

    Autor: Satan 24.10.12 - 10:24

    Unter Windows gibt es glaube ich ein Plugin, das dem Browser h264 beibringt.

  11. Re: Geht das nicht schon jetzt?

    Autor: nille02 24.10.12 - 10:41

    Satan schrieb:
    --------------------------------------------------------------------------------
    > Unter Windows gibt es glaube ich ein Plugin, das dem Browser h264
    > beibringt.
    Ja es gibt eins von Microsoft aber dies Funktioniert nicht mit FF16

  12. Re: Geht das nicht schon jetzt?

    Autor: sithik 24.10.12 - 13:11

    Thaodan schrieb:
    --------------------------------------------------------------------------------
    > Laut Youtube kann er es aber siehe:
    > imageshack.us

    Ähm, nö:

    Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0

    Sicher, dass du den Firefox hast? Eventuell gepatcht?

  13. Re: Geht das nicht schon jetzt?

    Autor: Thaodan 24.10.12 - 19:24

    nille02 schrieb:
    --------------------------------------------------------------------------------
    > Thaodan schrieb:
    > ---------------------------------------------------------------------------
    > -----
    > > Laut Youtube kann er es aber siehe:
    > > imageshack.us
    >
    > Sicher, dass du Firefox benutzt?
    >
    > www.abload.de
    Ja Firefox mit KDE Patch: https://aur.archlinux.org/packages.php?ID=32598
    Build Config:
    about:buildconfig
    Build Machine

    odin
    Build platform
    target
    x86_64-unknown-linux-gnu
    Build tools
    Compiler Version Compiler flags
    gcc gcc version 4.7.2 (GCC) -pedantic -Wall -Wpointer-arith -Wdeclaration-after-statement -Werror=return-type -Wtype-limits -Wempty-body -Wno-unused -Wno-overlength-strings -Wcast-align -Wno-long-long -march=native -mtune=native -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -fno-strict-aliasing -ffunction-sections -fdata-sections -pthread -pipe -DNDEBUG -DTRIMMED -g -fprofile-use -fprofile-correction -Wcoverage-mismatch -O3 -fomit-frame-pointer
    c++ gcc version 4.7.2 (GCC) -pedantic -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-offsetof -Wno-variadic-macros -Wcast-align -Wno-long-long -march=x86-64 -mtune=native -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -std=gnu++0x -pthread -pipe -DNDEBUG -DTRIMMED -g -fprofile-use -fprofile-correction -Wcoverage-mismatch -O3 -fomit-frame-pointer
    Configure arguments

    --enable-application=browser --prefix=/usr --libdir=/usr/lib --with-system-jpeg --with-system-zlib --with-system-bz2 --with-system-libevent --without-system-libvpx --enable-system-hunspell --enable-system-ffi --enable-system-pixman --enable-gstreamer --disable-libproxy --with-pthreads --enable-official-branding --enable-safe-browsing --enable-startup-notification --disable-gio --disable-gconf --disable-gnomevfs --disable-crashreporter --disable-updater --disable-tests --disable-mochitest --disable-installer --enable-optimize --enable-profile-guided-optimization

    Wahrung der Menschenrechte oder Freie fahrt am Wochenende.
    -- Georg Schramm

  14. Re: Geht das nicht schon jetzt?

    Autor: sithik 24.10.12 - 19:47

    Thaodan schrieb:
    --------------------------------------------------------------------------------
    > Configure arguments
    >
    > --enable-application=browser --prefix=/usr --libdir=/usr/lib
    > --with-system-jpeg --with-system-zlib --with-system-bz2
    > --with-system-libevent --without-system-libvpx --enable-system-hunspell
    > --enable-system-ffi --enable-system-pixman --enable-gstreamer
    > --disable-libproxy --with-pthreads --enable-official-branding
    > --enable-safe-browsing --enable-startup-notification --disable-gio
    > --disable-gconf --disable-gnomevfs --disable-crashreporter
    > --disable-updater --disable-tests --disable-mochitest --disable-installer
    > --enable-optimize --enable-profile-guided-optimization

    Also doch selber kompiliert, mit --enable-gstreamer. Hast du denn mal getestet, ob das überhaupt richtig funktioniert bei dir? Meines Erachtens nach ist das noch nicht fertig – um genau darum geht es ja in dem Artikel.

  15. Re: Geht das nicht schon jetzt?

    Autor: Thaodan 24.10.12 - 19:55

    sithik schrieb:
    --------------------------------------------------------------------------------
    > Thaodan schrieb:
    > ---------------------------------------------------------------------------
    > -----
    > > Configure arguments
    > >
    > > --enable-application=browser --prefix=/usr --libdir=/usr/lib
    > > --with-system-jpeg --with-system-zlib --with-system-bz2
    > > --with-system-libevent --without-system-libvpx --enable-system-hunspell
    > > --enable-system-ffi --enable-system-pixman --enable-gstreamer
    > > --disable-libproxy --with-pthreads --enable-official-branding
    > > --enable-safe-browsing --enable-startup-notification --disable-gio
    > > --disable-gconf --disable-gnomevfs --disable-crashreporter
    > > --disable-updater --disable-tests --disable-mochitest
    > --disable-installer
    > > --enable-optimize --enable-profile-guided-optimization
    >
    > Also doch selber kompiliert, mit --enable-gstreamer. Hast du denn mal
    > getestet, ob das überhaupt richtig funktioniert bei dir? Meines Erachtens
    > nach ist das noch nicht fertig – um genau darum geht es ja in dem
    > Artikel.
    Kein leider keine Seite die mir nur h.264 gibt. Viel muss da auch nicht getan werden da dies ja gstreamer übernimmt.

    Wahrung der Menschenrechte oder Freie fahrt am Wochenende.
    -- Georg Schramm

  16. Re: Geht das nicht schon jetzt?

    Autor: sithik 24.10.12 - 20:05

    Thaodan schrieb:
    --------------------------------------------------------------------------------
    > Kein leider keine Seite die mir nur h.264 gibt. Viel muss da auch nicht
    > getan werden da dies ja gstreamer übernimmt.

    Theoretisch ja, aber geht das bei dir?:
    [www.quirksmode.org]

    Bei mir kann er die MP4-Variante nicht abspielen, jedenfalls nicht in Firefox.

  17. Re: Geht das nicht schon jetzt?

    Autor: Thaodan 24.10.12 - 20:15

    sithik schrieb:
    --------------------------------------------------------------------------------
    > Thaodan schrieb:
    > ---------------------------------------------------------------------------
    > -----
    > > Kein leider keine Seite die mir nur h.264 gibt. Viel muss da auch nicht
    > > getan werden da dies ja gstreamer übernimmt.
    >
    > Theoretisch ja, aber geht das bei dir?:
    > www.quirksmode.org
    >
    > Bei mir kann er die MP4-Variante nicht abspielen, jedenfalls nicht in
    > Firefox.
    Mal abgesehen davon dass Fortschrittsleiste im Video immer wieder flackert wenn sich der Timer aktualisiert funktioniert alles ohne Probleme.

    Wahrung der Menschenrechte oder Freie fahrt am Wochenende.
    -- Georg Schramm

  18. Re: Geht das nicht schon jetzt?

    Autor: sithik 24.10.12 - 20:29

    Thaodan schrieb:
    --------------------------------------------------------------------------------
    > Mal abgesehen davon dass Fortschrittsleiste im Video immer wieder flackert
    > wenn sich der Timer aktualisiert funktioniert alles ohne Probleme.

    Gut, dann scheint es wohl prinzipiell erstmal soweit zu funktionieren.

    Das ändert aber nichts daran, dass es noch nicht fertig ist, wie man es auch an diversen Diskussionen mitverfolgen kann:
    [bugs.launchpad.net]
    [bugzilla.mozilla.org]
    [bugzilla.mozilla.org]

  19. Re: Geht das nicht schon jetzt?

    Autor: nille02 25.10.12 - 04:25

    Thaodan schrieb:
    --------------------------------------------------------------------------------
    > --enable-gstreamer

    Dann darfst du dich nicht hinstellen das Firefox 16.01 dies kann. Er kann es eben nicht und du hast ihn für dich einfach neu übersetzt.

  20. Re: Geht das nicht schon jetzt?

    Autor: Thaodan 25.10.12 - 06:05

    nille02 schrieb:
    --------------------------------------------------------------------------------
    > Thaodan schrieb:
    > ---------------------------------------------------------------------------
    > -----
    > > --enable-gstreamer
    >
    > Dann darfst du dich nicht hinstellen das Firefox 16.01 dies kann. Er kann
    > es eben nicht und du hast ihn für dich einfach neu übersetzt.
    Klar kann er es, nur nicht in den Builds von Mozilla selber, sonst würde ja --enable-gstreamer nicht gehen.

    Wahrung der Menschenrechte oder Freie fahrt am Wochenende.
    -- Georg Schramm

  1. Thema

Neues Thema Ansicht wechseln


Um zu kommentieren, loggen Sie sich bitte ein oder registrieren Sie sich. Sie müssen ausserdem in Ihrem Account-Profil unter Forum einen Nutzernamen vergeben haben. Zum Login

Stellenmarkt
  1. STRABAG AG, Stuttgart
  2. MRH Trowe, München, Düsseldorf, Frankfurt am Main, Alsfeld
  3. AUTHADA GmbH, Darmstadt
  4. ESWE Versorgungs AG, Wiesbaden

Golem pur
  • Golem.de ohne Werbung nutzen

Anzeige
Top-Angebote
  1. (u. a. externe Festplatten und SSDs günstiger, Apple generalüberholt reduziert)
  2. 166,99€ (Bestpreis!)
  3. (u. a. Asus ROG Strix B450-F Gaming-Mainboard für 98,95€)
  4. 69,99€ (Bestpreis!)


Haben wir etwas übersehen?

E-Mail an news@golem.de