1. Foren
  2. Kommentare
  3. OpenSource
  4. Alle Kommentare zum Artikel
  5. › Open Source: Python-Script…

Läuft nicht mit Blender >=2.80

  1. Thema

Neues Thema Ansicht wechseln


  1. Läuft nicht mit Blender >=2.80

    Autor: Dubu 01.06.20 - 17:18

    Leider hat sich in Blender 2.80 einiges geändert, sodass das Skript mit dieser Version oder neuer nicht mehr läuft. Es gibt bei den Github-Quellen einen Pull-Request vom Januar, um zumindest das Skript zum Laufen zu bekommen, aber leider ohne Materialien und Texturen.

  2. Re: Läuft nicht mit Blender >=2.80

    Autor: Tiles 02.06.20 - 08:33

    Tja, Golem ist hier halt mal wieder top aktuell. Das Script gibt es seit vier Jahren. Und funzt eigentlich nur für bis zu Blender 2.79 ... ^^



    1 mal bearbeitet, zuletzt am 02.06.20 08:35 durch Tiles.

  3. Re: Läuft nicht mit Blender >=2.80

    Autor: phiber 02.06.20 - 09:36

    Es gibt ein aktuelles Skript welches auch in der aktuellsten Blender Version läuft :
    a1studmuffin/SpaceshipGenerator/issues/31 ==> ldo/blender_spaceship_generator

    :-)

  4. Re: Läuft nicht mit Blender >=2.80

    Autor: Tiles 02.06.20 - 10:08

    Irgendwas stimmt an deinem Link nicht ^^

    EDIT, die Version hier sollte wohl gehen ... https://github.com/BlenderCN/add_mesh_SpaceshipGenerator

    EDIT2. aber auch die Version hat wohl kein Material und kein UV Mapping.



    3 mal bearbeitet, zuletzt am 02.06.20 10:13 durch Tiles.

  5. Re: Läuft nicht mit Blender >=2.80

    Autor: Dubu 02.06.20 - 11:12

    Das ist cool, danke. Leider ist dieser Fork wiederum unter Blender Version 2.82 erstellt und läuft nicht unter meinem Blender 2.80. Da bekomme ich entweder einen IndexError in Python oder Blender stürzt ab. :-(
    Muss wohl ein Blender-Update her.

    (Der vollständige Link zum Fork: https://github.com/ldo/blender_spaceship_generator)



    2 mal bearbeitet, zuletzt am 02.06.20 11:18 durch Dubu.

  6. Re: Läuft nicht mit Blender >=2.80

    Autor: 7of9 02.06.20 - 14:33

    Dubu schrieb:
    --------------------------------------------------------------------------------
    > Leider ist dieser Fork wiederum unter Blender Version
    > 2.82 erstellt und läuft nicht unter meinem Blender 2.80. Da bekomme ich
    > entweder einen IndexError in Python oder Blender stürzt ab. :-(
    > Muss wohl ein Blender-Update her.

    Da sieht man mal, dass beim dem Open Source Gerödel auch nicht alles Gold ist was glänzt :-)

    #USA #Frau
    „I pledge allegiance to the flag of the United States of America, and to the republic for which it stands, one Nation under God, indivisible, with liberty and justice for all.“

  7. Re: Läuft nicht mit Blender >=2.80

    Autor: danh 03.06.20 - 09:35

    7of9 schrieb:
    --------------------------------------------------------------------------------
    >
    > Da sieht man mal, dass beim dem Open Source Gerödel auch nicht alles Gold
    > ist was glänzt :-)

    Was hat das mit Open-Source-Gerödel zu tun, wenn ein Addon, dass für eine API Version 2.82 erstellt bzw. auf Basis dieser Version aktualisiert wurde, nicht mit der Version 2.80 läuft?

    Der Vorteil in dem speziellen Fall ist übrigens, dass wenn man aus welchen Gründen auch immer weiterhin 2.80 verwenden will, statt 2.82, man dies absolut ohne jegliche Probleme parallel benutzen kann.

  8. Re: Läuft nicht mit Blender >=2.80

    Autor: 7of9 03.06.20 - 09:45

    danh schrieb:
    --------------------------------------------------------------------------------
    > 7of9 schrieb:
    > ---------------------------------------------------------------------------
    > -----
    > >
    > > Da sieht man mal, dass beim dem Open Source Gerödel auch nicht alles
    > Gold
    > > ist was glänzt :-)
    >
    > Was hat das mit Open-Source-Gerödel zu tun, wenn ein Addon,

    Allein schon, dass du dir um den Versions-Wirwarr Gedanken machen musst!

    siehe:
    > dass für eine
    > API Version 2.82 erstellt bzw. auf Basis dieser Version aktualisiert wurde,
    > nicht mit der Version 2.80 läuft?
    >
    > Der Vorteil in dem speziellen Fall ist übrigens, dass wenn man aus welchen
    > Gründen auch immer weiterhin 2.80 verwenden will, statt 2.82, man dies
    > absolut ohne jegliche Probleme parallel benutzen kann.

    #USA #Frau
    „I pledge allegiance to the flag of the United States of America, and to the republic for which it stands, one Nation under God, indivisible, with liberty and justice for all.“

  9. Re: Läuft nicht mit Blender >=2.80

    Autor: 1e3ste4 03.06.20 - 14:48

    7of9 schrieb:
    --------------------------------------------------------------------------------
    > Allein schon, dass du dir um den Versions-Wirwarr Gedanken machen musst!

    Das gibt es überall und ist ganz normal. Auch bei Closed-Source-Gerödel. Software entwickelt sich halt weiter.

  10. Re: Läuft nicht mit Blender >=2.80

    Autor: danh 03.06.20 - 14:55

    Und das musst du bei closed source Software nicht?

    Es gibt komplette Anwendungen, die setzen z. B. Windows 10 Reversion xyz voraus, um funktionieren zu können oder gewisse macOS, iOS oder Android Versionen, das ist absolut nichts ungewöhnliches.

    Eine fortlaufende Nummerierung ist schätze ich mal stark objektiv belegbar das geordnetste, was die Menschheit so kennt, von daher erscheint mir der Ausdruck "Wirrwar" doch etwas ungeeignet, wenn es nun um sowas wie "Catalina", "Mojave", "High Sierra" ginge, könnte ich das ja noch halbwegs verstehen, denn das folgt keiner allgemein akzeptierten Ordnung, z. B. dass "Mojave" > "Catalina" dem Alphabet folgend sei.



    1 mal bearbeitet, zuletzt am 03.06.20 14:56 durch danh.

  11. Re: Läuft nicht mit Blender >=2.80

    Autor: 7of9 03.06.20 - 14:58

    1e3ste4 schrieb:
    --------------------------------------------------------------------------------
    > 7of9 schrieb:
    > ---------------------------------------------------------------------------
    > -----
    > > Allein schon, dass du dir um den Versions-Wirwarr Gedanken machen musst!
    >
    > Das gibt es überall und ist ganz normal. Auch bei Closed-Source-Gerödel.
    > Software entwickelt sich halt weiter.

    Selten, da man sich die Addons in der Regel für die aktuelle Software Version kauft.

    #USA #Frau
    „I pledge allegiance to the flag of the United States of America, and to the republic for which it stands, one Nation under God, indivisible, with liberty and justice for all.“

  12. Re: Läuft nicht mit Blender >=2.80

    Autor: danh 03.06.20 - 15:04

    Ja und die ist gerade nun mal 2.82 und nicht 2.80 - und wenn jemand im Januar das Addon aktualisiert hat, dann ist es durchaus legitim, wenn dafür modernste Funktionen der API Version 2.82 benutzt werden und man keine Lauffähigkeit mit veralteten Versionen hat.

    Dass jemand überhaupt in der Lager war, es kompatibel zur Version 2.82 zu machen obwohl es vom ursprünglichen Entwickler nicht mehr gepflegt wurde, ist doch eher das, was an Open-Source-Software glänzt und es gibt wahrhaftig einiges, was daran wirklich oftmals nicht glänzt, aber das und insbesondere im Falle von Blender doch nicht.

    Das war nämlich ein Versionssprung mit teilweisem Verlust der Rückwärtskompatibilität, der natürlich immer schmerzt aber manchmal notwendig ist.

    Macht man z. B. auch mal mit anderen Systemen zur Informationsverarbeitung hin und wieder z. B. mit Postleitzahlen glaube 1995(?).



    4 mal bearbeitet, zuletzt am 03.06.20 15:15 durch danh.

  1. Thema

Neues Thema Ansicht wechseln


Um zu kommentieren, loggen Sie sich bitte ein oder registrieren Sie sich. Sie müssen ausserdem in Ihrem Account-Profil unter Forum einen Nutzernamen vergeben haben. Zum Login

Stellenmarkt
  1. LOTTO Hessen GmbH, Wiesbaden
  2. über duerenhoff GmbH, Raum Garching
  3. PHOENIX CONTACT Energy Automation GmbH, Velbert
  4. Versicherungskammer Bayern, München

Golem pur
  • Golem.de ohne Werbung nutzen

Anzeige
Spiele-Angebote
  1. 16,49€
  2. (u. a. Rage 2 für 11€, The Elder Scrolls V: Skyrim Special Edition für 11,99€, Doom Eternal...


Haben wir etwas übersehen?

E-Mail an news@golem.de


Arlt-Komplett-PC ausprobiert: Mit Ryzen Pro wird der Büro-PC sparsam und flott
Arlt-Komplett-PC ausprobiert
Mit Ryzen Pro wird der Büro-PC sparsam und flott

Acht Kerne, schnelle integrierte Grafik, NVMe-SSD direkt an der CPU: Ein mit Ryzen Pro 4000G ausgestatteter Rechner ist vielseitig.
Ein Hands-on von Marc Sauter

  1. Udoo Bolt Gear Mini-PC stopft Ryzen-CPU in 13 x 13 Zentimeter
  2. Vermeer AMD soll Ryzen 4000 mit 5 nm statt 7 nm produzieren
  3. Vermeer AMD unterstützt Ryzen 4000 auf X470 und B450

MS Flight Simulator angespielt: Airbus 320neo mit Tastatur gesteuert
MS Flight Simulator angespielt
Airbus 320neo mit Tastatur gesteuert

Wie fliegt sich der Airbus 320neo? Golem.de hat es am PC ausprobiert - und von den Entwicklern mehr über den Flight Simulator erfahren.
Von Peter Steinlechner

  1. Microsoft Flight Simulator startet auf Steam und fliegt mit Valve-VR
  2. Microsoft Flight Simulator enthält eigenen Marktplatz
  3. Aerosoft MS Flight Simulator kommt auf 10 DVDs in den Handel

Mars 2020: Was ist neu am Marsrover Perseverance?
Mars 2020
Was ist neu am Marsrover Perseverance?

Er hat 2,5 Milliarden US-Dollar gekostet und sieht genauso aus wie Curiosity. Einiges ist dennoch neu, manches auch nur Spielzeug.
Von Frank Wunderlich-Pfeiffer